What is the PHP update? And how to update PHP in WordPress?

What is the PHP update? and What is the PHP version? Before updating your PHP check it out first either you even need it or not. You have multiple ways to do this, but let’s keep it simple and use a plugin called display PHP version.


Is the PHP update will affect my site?

That relies upon how you’ve assembled your site. Your webpage is made with HTML, similar to Website Builder; at that point, the PHP update has no impact by any means. 

If your webpage is made with PHP and the code is viable with the new PHP rendition, your site will work the equivalent, or better you utilize a CMS like WordPress, you can presumably see a few enhancements in execution if you have restored WordPress to the most recent rendition.  I use code that is obsolete and not upheld in the fresher form of PHP; at that point, your site will give blunders and may quit working by and large. For instance, if you haven’t restored your CMS to the most recent adaptation, or if your site utilizes custom code, for which an update isn’t promptly accessible. You have to refresh the code to make it viable.


PROS of updating

Better security 

The most evident motivation to refresh is security. More current variants are better at countering programmers, for instance, because belittled (obsolete) code is not, at this point upheld.

Quicker sites 

Newer PHP variants are quicker. PHP 7.4 is altogether quicker than the past variants, and with speedier execution times and less memory utilization, particularly WordPress locales will profit. 

New highlights and enhancements 

As with all updates, a fresher adaptation remembers new highlights and upgrades for how to get things done, for instance, preloading.

What to do?

Just install and activate it and go to your dashboard under the at-a-glance section. You’ll see that you’re currently running PHP version 5.6.0.  

It’s consistently somewhat hazardous to redesign. Since it’s conceivable that your site contains code that the new PHP variant won’t be viable with. We should turn out how to keep that from occurring since PHP issues. Generally have to do with old code its ideal to overhaul your modules subject in WordPress form. Before you do whatever else you ought to back up your site before busy consistently. Repairing all that is outdated is decent, yet it’s not idiot-proof.

 There are a few ways to upgrade your PHP. Some are pretty advanced, like using SSH commands.


How to update the version of PHP your WordPress site?

How to update the version of PHP your WordPress site is using. WordPress is built on, and your web hosting company sets the performance of PHP that your site is running on. So that’s why you have to update it yourself, and I know that you’re familiar with updating all the other aspects of your WordPress site, like your themes and your plugins, but your PHP will need to be updated over time as well.  

The two main benefits of updating your version of PHP are:

  • Your WordPress blog will be faster and more secure so updating
  • It will have a positive effect on your site’s performance and with that being said 

WordPress started issuing this warning within the dashboard, letting you know that a PHP update is required. It looks kind of scary at first, but trust me it’s super simple to fix once you know what to do. 

Update your version of PHP through your Cpanel

Follow the steps and update your version of PHP pretty quickly. Before doing anything, it’s highly recommended that you download install and activate the PHP compatibility checker plugin. Checks the compatibility of your site and your plugins against new versions of PHP. It will also report any issues if there are any and show you what needs to be fixed. Before updating your version of PHP, after you’ve installed and activated the PHP compatibility plugin you can access it in. 

Here are some guiding steps which make you able to update the PHP version in WordPress:

  • Then click on PHP compatibility, and this brings you to the scanning options 
  • It’s pretty straightforward you can set the version of PHP that you want to check the compatibility of 
  • If you’re checking 7.3 so make sure that’s selected 
  • Then the plugin theme status lets you choose between scanning all the plugins 
  • Themes are only active plugins and themes 
  • Let’s start your scan, select what you want to scan 
  • Click the scan of the site button. 
  • Then the plugin goes to work now it will take a few seconds 
  • But you should see a status bar as the plugin starts checking the compatibility of your site 
  • It depends on how many plugins you have and what kind of theme you’re running 
  • It will take a few minutes for the scan to complete so just a heads up on that now 
  • While your scan completes, the plugin will report the results for PHP 7.3 compatibility below on the same screen 
  • Then you can review and see what needs your attention 
  • Now the green check marks with compatible next to them are good to go 
  • You don’t need to worry about those and then make sure you don’t have any that are marked not compatible which are good 
  • We have some that are marked as unknown this is usually due to the plugin or theme being skipped 
  • During the scan, because it was too large to scan before the server killed the process so if that’s the case, then you may have to do a quick google search to make sure that the plugin or theme is compatible with the version of PHP
  • You want to update to, and I know it’s not a perfect science, but one thing I can say is that if its developers regularly update your plugin and as a popular and well-known plugin the chances are it’s going to be compatible with the most recent version of PHP
  • However, it never hurts to double-check for example the Yoast SEO plugin a very well-known and popular plugin came back as unknown on our scan report
  • However we visit the Yoast website and view their plugin requirements page, you can see that they recommend the PHP version 7.3 or above 
  • So we’re good to go there. Next, the wp forms plugin came back as unknown in our report, but after a little detective work, we can see that wp forms also recommends having PHP 7.3 or greater. 
  • So we’re right there as well, and the list goes on the jetpack plugin is also compatible with PHP 7.3 as verified by one of the plugins developers, so the chances are that if your scan says unknown, you’re probably. But I highly recommend doing a quick Google search of the plugins that came back as new to make sure.
  • So after you’ve run the compatibility scan and reviewed all the plugins and themes for their compatibility with PHP 7.3, it’s time to update now 
  • Update your PHP o go back to Bluehost and access the Cpanel and again if you’re using a different web host go ahead and take the necessary steps to access your Cpanel
  • Then if you are using Bluehost if you’re back at the Bluehost dashboard click on the advanced tab to access your Cpanel 
  • What you’re looking at right now is the Cpanel commonly referred to as the control panel 
  • If you’re new to all this, the multi-PHP manager is a piece of software that allows you to manage your account’s PHP configuration easily. So we’re going to use it to update our version of PHP.  
  • To do that in your Cpanel scroll down to the software section 
  • Click on the multi PHP manager icon, and then this will bring you to the back end of the software where you can set the domain that you want to apply the new version of PHP. 
  • You’ll notice that even Bluehost is warning us that we need to update because the PHP that we’re using is going to be depreciated 
  • We’ll need to update that so to update the version of PHP find the domain that you want to update 
  • Check the box next to it then find the PHP version 
  • Drop-down and select PHP 7.3, and some might be listed as PHP 7.3 but go ahead and select the one that you want to use 
  • Then click the apply button, and after a few seconds, you’ll get a notification letting you know that the update was successful.

Then if we go back to a WordPress blog and back at the dashboard, you’ll notice that the scary PHP warning is gone and we are now running the most up-to-date version of PHP.

On-site now one way to stay on top of the PHP updates is to use a lightweight plugin called version info. This plugin displays the current WordPress version number along with the PHP version of the webserver. User version within the footer of your WordPress dashboard. Scroll down to the bottom of the dashboard quickly. You can see that after installing and activating the version info plugin PHP 7.3 is displaying, and it ensures us, that we’ve successfully updated our version of PHP on our WordPress blog.


What is the PHP update error in how to update PHP in WordPress?

This error which you’re getting on my WordPress dashboard, so this error is PHP update is a bit required. So if you want to remove this error from WordPress and function your website quickly and efficiently, for this, you have to log in to the web hosting and update the PHP version. So let’s login to your web hosting, whatever you are using like, Go Daddy or anything else, so you have to log in to their account. Open Cpanel, in Cpanel you need to scroll down as per the interface of your Cpanel.

 It would help if you went to these options software under software you can see. There is an option of a multi PHP manager, click, so you can see your current version of PHP is 7.3. But might window pop-up with the beta version and this is the reason why you’re facing a problem. This is the inherited beta version, so first need to select your domain click on the check-in the one button, and you need to go there PSP version. This option you need to click over here. 

This is all are the PSP versions, and this is inherited inherit PHP 7.3. when the full version of 7.3 will launch, you will again move 7.3, but as of now it is a beta version so switch to 7.2 and click on apply. You will see these matches successfully used PHP version 7.0. So now it will take some time to remove this error from your dashboard. It will take some hours, but sometimes it gets removed immediately. Just refreshes your page and check it’s remote immediately. If yes, then an error has been removed. There is no error now, so you can also use this step and remove this PHP error and change the version of PHP using your Cpanel.


Final words

Stay up-to-date is good and makes you and your things more advanced. Doesn’t matter is this your personal or professional thing. If you are a WordPress web host and running your website than this PHP update will indeed accommodating for you. This article is a complete guide on how to update PHP in WordPress. Follow the above mention steps for editing and make your work smooth.